Как я могу получить debuild поставить двоичный файл в /usr/Бен?

Я недавно пытался пакет небольшой утилиты на Python, чтобы положить на мой ППА и я почти получил его на работу, но у меня возникли проблемы в создании пакета установки двоичный файл (командой chmod +x на скрипт Python) в /usr/Бен. Вместо этого он устанавливает под /. Я эту структуру каталогов -> http://db.tt/0KhIYQL.

Мой Makefile пакета выглядит так:

Цель=УСР/бин/txtrevise

сделать:
 чмод +х $(цель)

установить:
 СР -Р $(целевой) $(destdir, в)

Я использовал $(destdir, в), как я понимаю, чтобы поместить файл под Debian с каталогом, когда debuild запускается.

У меня txtrevise скрипт, мой исполняемый под УСР/бин папку в корень моего пакета. У меня также есть файл Makefile и УСР/бин/textrevise в мой архив: txtrevise_1.1.original.tar.gz.

Однако, когда я построить и заглянуть внутрь пакет Debian, txtrevise всегда находится в корневой папке, а не по УСР/Бин и будет установлен до / вместо /usr/Бен.

Как я могу получить debuild поставить скрипт в нужном месте?

Спасибо. Любая помощь будет высоко оценили. Я в тупике.

+302
GiGi 12 мая 2016 г., 18:29:42
25 ответов

Что касается ГПЛ вопрос, Да, вы можете связать с GPL приложения, наряду с не-GPL приложения, пока последнего не производные первого и вы не нарушаете условия GPL приложения, вы корабль.

Увидеть соответствующую запись на GPL FAQ на сайте.

Как другие люди упомянули, вам также может понадобиться, чтобы рассмотреть Убунту маркой политики. Что для вашего случая, вероятно, просто означает маркировка CD как ремикс Убунту, а не саму Убунту.

Для чего вы говорите о, это звучит хорошо, но типичный IANAL квалификации применять.

+874
1bit0fMe 03 февр. '09 в 4:24

Подобный вопрос был задан и ответил на суперпользователя Как установить НФС раздел в Ubuntu, как читать/писать

Вы можете последовать ответ и дайте нам знать, если это решает вашу проблему?

+795
armaliko 15 июн. 2018 г., 19:16:06

Вам не нужно использовать Visual Studio, чтобы доступ к MS SQL серверу. Если вы разрабатываете приложения (как упомянуть визуальные студии предполагает), вам нужна библиотека для языке, который позволит вам подключиться к серверу.

Какой язык вы используете?

Например, для Python есть pymssql

Там же FreeTDS, который, как я понимаю, представляет собой набор инструментов командной строки и библиотеки для подключения к MSSQL и Sybase серверов.

В любом случае, я думаю, было бы очень трудно установить Visual Studio в ОС Ubuntu (ну, кроме установки внутри экземпляра VirtualBox с ОС Windows).

+737
Fetus 1 нояб. 2011 г., 16:55:25

Вам нужна одна графическая карта для запуска любой операционной системы. Не имеет значения, если она встроенная, АГП, PCI или что угодно.

+702
Mihir Vohra 29 нояб. 2018 г., 18:26:44

Я увидел рабочего стола Switcher в PearOS такой:

Desktop Switcher in PearOS screenshot

Я могу же в моей Убунту 12.04? Я установил PearOS, но я не нашел название этого настольного коммутатора.

Спасибо за помощь.

+694
Nicki B 5 мар. 2018 г., 18:06:31

Я более или менее решил проблему. Это не идеально, но это работает. В Настройки CompizConfig, общие параметры -> комбинации клавиш, есть две настройки для "поднять окно", управляет мышью и клавиатурой. Я поставил управление мышью супер+кнопка button1, которая не конфликтует с Alt+button1 в окне "переместить" варианты. Я тоже поставил "нижнее окно" супер+элемент button2, для ортогонального работает с кнопки на заголовке.

Хотя это не совместить поднять+нижний, как я привык, это позволяет мне получить доступ к поднять/опустить при использовании мыши, так что это достаточно хорошо для моих целей.

+637
deadwars 14 дек. 2014 г., 12:44:36

Если переустановка синаптикс не работает. Попробуйте добавить это к вашему /etc/Х11/файл xorg.файл conf. Вы должны иметь его, если у вас установлен драйвер Nvidia. Если не создать его.

Раздел "InputClass"
 Идентификатор "тачпад"
 Водитель "синаптикс"
 MatchIsTouchpad "о"
 Вариант "TapButton1" "1"
 Вариант "TapButton2" "2"
 Вариант "TapButton3" "3"
 Вариант "VertEdgeScroll" "о"
 Вариант "VertTwoFingerScroll" "о"
 Вариант "HorizEdgeScroll" "о"
 Вариант "HorizTwoFingerScroll" "о"
 Вариант "CircularScrolling" "о"
 Вариант "CircScrollTrigger" "2"
 Вариант "EmulateTwoFingerMinZ" "40"
 Вариант "EmulateTwoFingerMinW" "8"
 Вариант "CoastingSpeed" "0"
EndSection
+614
zuleyka 14 мар. 2017 г., 15:45:55
Вопросы о шифровании, такие как шифрование домашней папки, шифрование раздела и шифрование файлов.
+566
Dorothy Fluker 17 мая 2012 г., 17:29:59

с:

кошка /proc/перегородки

вы можете увидеть все обнаруженные разделы ядром, в формате "правильного"

с:

массива.для vfat /dev и/

будет отформатирована с файловой системой FAT32

+513
Blaise Causby 17 мар. 2019 г., 1:23:29

Я всегда использую Универсальный USB Installer из pendrivelinux , чтобы сделать мои настойчивые загрузочных USB-накопителей. Работает как часы и регулярно пополняется новыми дистрибутивами. Конечно, я использую Windows, то для их создания и если вы не имеете доступ к одному из них, к сожалению, это не решение для вас.

+475
sl0vaj 10 сент. 2014 г., 1:23:22

Она предназначена для операционных систем GNU/Linux и использует инструментарий Qt для графического пользовательского интерфейса. Для сигналов вызова, он использует протокола инициации сеанса (SIP). Она также имеет прямой IP к IP-звонков. Медиапотоки передаются в режиме реального времени транспортный протокол (РТП), которые могут быть зашифрованы с помощью в режиме реального времени транспортный протокол (протокол SRTP) и протоколы безопасности ZRTP и SRTP.

+444
user3200318 1 февр. 2011 г., 5:33:17

Возможные Дубликаты:
Как мне добавить себя как пользователя sudo?

Я исследовал в учетные записи пользователей. У меня есть только мой счет, но я поменял от администратора стандарт. и я не могу поставить к администратору снова, потому что это requets пароль, я положил мой древний, но он не принимает. Мне нужен мастер-пароль или что-то так. Я не могу установить ни удалить любое приложение. также я не могу войти root или суперпользователя.что я могу сделать, чтобы быть как раньше.

+435
Nick Dixon 9 окт. 2013 г., 9:37:19

Наконец-то я нашел

Строка [] extCmdArgs = новая строка[]{"архив запросов", "-Ш", "-Ф=${пакет} ${версия}\п"};
Процесс fetchInstalledPackagesProcess = время выполнения.getRuntime().метод exec(extCmdArgs);
Командой bufferedreader читатель = нуль;
 попробовать {
 читатель = читает(новый InputStreamReader(fetchInstalledPackagesProcess.getInputStream()));
 Строки;
в то время как(правда){
 строка = читатель.с readline();
 если (строка == нуль)
перерыв;
Системы.из.метод println(линия);
}
 } поймать (исключение e) {
е.печатные();
}
 наконец, {
читатель.закрыть();
}
+400
nijanthanh 15 дек. 2017 г., 16:03:50

Здесь представлены инструкции, но будьте уверены, чтобы знать, что ты делаешь.

На каждый *Никс системе вы найдете файл с названием файл/etc/passwd в котором перечислены все пользователи и некоторые параметры. Вот синтаксис этого файла:

логин:пароль:жидкость:гид:additional_info:дом:корпус

Так, например, вы найдете:

корень:х:0:0::/корень:/бин/Баш

Что означает, что пользователь называется root, пароль скрыт (это в файле/etc/тень), uid равен 0, gid равен 0, дополнительная информация, в домашний каталог /корень и умолчанию оболочка /бин/Баш.

Редактировать этот файл и изменить домашний каталог.

Однако, я не вижу никаких причин делать это.

+337
everygamer 20 дек. 2013 г., 1:44:36

Я недавно включил композитинг в моем ноутбуке с помощью следующей команды:

gconftool-2 -х --типа bool /приложения/перевод/общие/compositing_manager правда

Производительность, кажется, же после, что кроме того, что есть небольшая заметная задержка при переключении между окнами, теперь, когда я нажимаю АЛТ+таб. Кроме того, там сейчас немного лагает, когда я играю в игры в Teeworlds (не интенсивного графика).

Мой ноутбук является низким уровнем конца, поэтому я не уверен, если это просто моя видеокарта. Я дискутирую, если мне нужно установить проприетарные драйвера для улучшения производительности. Могу ли я получить некоторые советы по этому поводу?

вывод результата команд lspci | грэп -я ВГА выглядит следующим образом:

01:05.0 VGA совместимый контроллер: технологии ATI M880G Инк [мобильности Radeon серии HD 4200]

Я не уверен, что водители в настоящее время я использую, но я знаю, что я ничего не трогал с момента установки кармических 9.10, так что я знаю, что я использовал открытый источник. В настоящее время я использую 10.04 ЛТС (модернизированный, а не чистой установки).

+318
Paulo Roberto Candido dos Sant 14 дек. 2016 г., 21:24:26

Я нашел решение именно этого вопроса в другой теме: Единство пропали почти все ярлыки

Решение, поэтому вам не нужно искать его:

gsettings сброс орг.с Compiz.сердечник:/орг/менеджер/профили/единство/Плагины/основной/ активный-Плагины
+276
agentofuser 30 июл. 2012 г., 19:36:30

Я хочу, чтобы фильтровать результаты в единстве всегда показывают. Как это возможно? Я использую Ubuntu 12.04. Смотрите скриншот:

filter result show

+238
somecallmejosh 6 июл. 2015 г., 7:16:52

Я хочу, чтобы запустить приложение Windows в Ubuntu с помощью Wine. Однако, из прошлого опыта я знаю, что это может быть неприятно, сложный процесс из-за вина и аппаратных ошибок. Что лучше, канонический способ устранения проблемы с которыми я сталкиваюсь, пытаясь установить и запустить данное приложение?

+200
user67827 10 июн. 2012 г., 13:48:19

Я использую 12.04 и есть на принтер Canon MP288. Поскольку цветные картриджи стоят так дорого я хочу печатать только с помощью черного картриджа, но там, кажется, нет способа сделать это, и ответов здесь пока не работают. Я уверен, что это было возможно в Windows. Это просто проблема с драйвером?

+190
user270592 27 янв. 2012 г., 21:19:43

В настоящее время мои терминала выглядит так:

blankman-Макбук-Про:~ $

Мой .файл имеет:

экспорт и PS1="\[\033[36М\]\Ч:\Ш \[\033[33м\]\$(parse_git_branch)\[\033[00м\]\$(ЖКТ конфигурации пользователя.инициалы)$\[\033[00м\] "
экспорт SUDO_PS1='\[\е[0;31М\] и\U\[\Е[Г\] \[\Е[1;высота 34m\]\ш\[\е[г\] \[\е[0;31М\]\$ \[\е[0м\]'

Есть ли в этом смысл?

+166
shahrussia 10 авг. 2014 г., 9:38:02

Запустив PowerTOP на основе Ubuntu 10.10 система, одним из предложений

Включить CONFIG_PM_ADVANCED_DEBUG параметр конфигурации ядра. Это опция позволит PowerTOP для сбора управление статистики во время выполнения власти.

Какой параметр конфигурации ядра и как его включить?

Я могу поставить его в качестве параметра запуска, или мне придется скомпилировать новое ядро?

+140
woojink 25 февр. 2019 г., 3:48:54

Перейти к https://repogen.simplylinux.ch.

Выберите вашу страну и выпуск Ubuntu.

По умолчанию набор репозиториев, вы должны включить эти репозитории.

  • Все филиалы репозитории Убунту.
  • Безопасность - Важные Обновления Безопасности.
  • Источники Безопасности Репозитория
  • Обновления Рекомендуемые Обновления
  • Источники Обновления Репозитория

Если вы хотите установить программное обеспечение от канонических репозитории партнеров (закрытый исходный код), включить в репозиториях партнеров Убунту (обоих из них).

Включите 3 репозитория партии, которую вы хотите включить.

Теперь, нажмите кнопку Создать список в нижней части этой страницы, и вы увидите ваш сгенерированный источников.список.

Замену старых источников.список с новой

Выполните следующие команды в терминале.

судо МВ /и т. д./кв/источников.список /и т. д./кв/источников.список.старый
gksudo команду Gedit /и т. д./кв/источников.список

Копировать/вставить весь текст из недавно созданных ресурсов.список в этот файл. Сохраните его и закройте окно gedit.

Теперь, обновление АПТ.

судо apt-получить обновление

Это обновит свой индекс репозитория с источниками тока.список, а затем вы можете установить любое программное обеспечение с помощью программного обеспечения центр, Synaptic или APT-получить.

+130
Ello 15 окт. 2015 г., 8:43:18

У меня на ATI 5670 HD качестве. Я с Ubuntu 12.10 64-битной. У меня возникли адское время, пытаясь установите самые последние драйверы для видеокарты. Все остальное, кажется, работает за исключением видеокарты. Это новая установка на новый раздел.

Я следовал инструкциям к письму здесь: http://wiki.cchtml.com/index.php/Ubuntu_Quantal_Installation_Guide

И моя карта наверняка поддерживается драйверами, я знаю это наверняка, потому что в другом разделе у меня 32 разрядная система, где оба катализатора 13.1 и 13.2 работать безотказно:

команда sudo lshw -C с видео
ЧКВ (файловой системы) 

 *-дисплей невостребованным 
 описание: совместимый контроллер VGA и 
 продукт: Редвуд [Radeon серии HD 5670]
 поставщик: передовые микро устройства [драмов] в девичестве АТИ
 физический идентификатор: 0
 автобусная информация: [email protected]:01:00.0
 версия: 00
 ширина: 64 бит
 часы: 33мгц
 возможности: ПМ разъем pciexpress bus_master cap_list МСИ vga_controller
 настройки: время задержки=0
 ресурсы: память:d0000000-dfffffff памяти:fbee0000-fbefffff ioport:от e000(размер=256) память:fbec0000-fbedffff

Затем я попытался с помощью этого инструмента (который по сути дублирует инструкции, руководства): http://www.thefanclub.co.za/how-to/ubuntu-amd-catalyst-install

Что я в итоге всегда одинаково, независимо от того, какие драйверы (13.1,13.2) я установить на систему.

$ fglrxinfo 
Ошибка х неудачных запросу: BadRequest (неверный код запроса или нет такую операцию)
 Основные операции невыполненных запросов: 155 (ATIFGLEXTENSION)
 Незначительные операции невыполненных запросов: 66 ()
 Серийный номер не просить: 13
 Текущая серийный номер в выходной поток: 13

Я отследил, что я верю, чтобы быть проблемой в процессе ручной установки:

(Чтение базы данных ... 198845 файлы и каталоги установлены.)
Готовится сменить fglrx от 2:9.000-0ubuntu3 (используя fglrx_12.100-0ubuntu1_amd64.деб) ...
Удалив все применением DKMS модули
Сделано.
Распаковка fglrx от замены ...
Готовится сменить fglrx от-amdcccle 2:8.970-0ubuntu1 (через fglrx от-amdcccle_12.100-0ubuntu1_amd64.деб) ...
Распаковка замена fglrx от-amdcccle ...
Готовится сменить fglrx от-Дев 2:8.970-0ubuntu1 (через fglrx от-dev_12.100-0ubuntu1_amd64.деб) ...
Распаковка замена fglrx от-Дэв ...
Установка fglrx от (2:12.100-0ubuntu1) ...
обновление-альтернатив: предупреждение: принуждение переустановка альтернативы /usr и/lib в/fglrx от/ЛД.так.conf, поскольку группы ссылок x86_64 с-Линукс-gnu_gl_conf сломан
обновление-альтернатив: предупреждение: принуждение переустановка альтернативы /usr и/lib в/fglrx от/ЛД.так.conf, поскольку группы ссылок x86_64 с-Линукс-gnu_gl_conf сломан
обновления-пакет initramfs: отложить обновление (триггер активирован)
Загрузка новый fglrx от-12.100 файлов формате HTML...
Дом только для 3.5.0-17-generic и
Здание для архитектуры x86_64
Сборки модуля для текущего ядра был пропущен, поскольку
исходный код ядра для этого ядра, кажется, не быть установлен.
обновления-пакет initramfs: отложить обновление (триггер активирован)
Обработка триггеры для ureadahead ...
Обработка триггеров для bamfdaemon ...
Восстановление /usr/доли/приложения/фумб.индекс...
Установка fglrx от-amdcccle (2:12.100-0ubuntu1) ...
Установка fglrx от-Дэв (2:12.100-0ubuntu1) ...
Обработка триггеров для образа initramfs-инструменты ...
обновления-пакет initramfs: генерацией /boot/initrd он.ИМГ-3.5.0-17-универсальный
Обработка триггеров для библиотеки libc-Бен ...
команду ldconfig отложенной обработки, которые сейчас происходят

Ту часть, где написано "обновление альтернатива" не представляет себя в дублированном процесс установки на мой 32бит установить Ubuntu на одном компьютере:

обновление-альтернатив: предупреждение: принуждение переустановка альтернативы /usr и/lib в/fglrx от/ЛД.так.conf, поскольку группы ссылок x86_64 с-Линукс-gnu_gl_conf сломан
+84
Lera S 17 янв. 2013 г., 20:59:22

Хорошие новости: Хомяк-индикатор приближается к точным, так что вам не нужно использовать ППА. Благодаря Альберто, bojo42, и Джейми!

Ошибка #686062 “Ффе: хомяк-апплет должен иметь appindicator д...” : ошибки : “хомяк-апплет” пакет : Убунту

+21
fifolo 22 июн. 2016 г., 7:22:20

Amd64 и 64-разрядные версии

enter image description here

Вы можете скачать ее на http://www.ubuntu.com/download/desktop

+12
abra 28 окт. 2018 г., 2:12:25

Показать вопросы с тегом